今天手贱升级了一个pkg版本,从pkg-1.9.3升级到pkg-1.9.4_1。然后就不能用了。提示
/usr/local/lib/libpkg.so.3: Undefined symbol "openat"
pkg命令不能用了。好像是内核版本太低了。就找了一下怎么解决。

有个pkg-static命令可以使用,,然后/var/cache/pkg里边缓存的包。执行命令:
pkg-static install -f /var/cache/pkg/pkg-1.9.3.txz
强制换低版本的pkg。然后就好了。。没有这个包可以去freebsd官网下一个。

上一篇:
下一篇:

相关文章:

Categories: 博客记录

0 Responses so far.

Leave a Reply